Перейти к блогу GetChip.net - блог        JilTE[1] - в разработке     Модификации устройств - модификации

 
Текущее время: 16 окт 2018, 06:03

Часовой пояс: UTC + 3 часа [ Летнее время ]



Начать новую тему Ответить на тему  [ Сообщений: 161 ]  На страницу Пред.  1 ... 13, 14, 15, 16, 17  След.
Автор Сообщение
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 30 май 2017, 06:57 
Не в сети

Зарегистрирован: 22 май 2017, 12:37
Сообщения: 27
Откуда: омск
SVN писал(а):
Твоя схема верная, это я не туда посмотрел. Если собрана без ошибок, то работает сразу нормуль. Программа проверена неоднократно на девбордах.

Наверно касячная тинька попалась купленая на али попробую прошить другую. Так значит всётаки 37 кгц на второй ноге должно быть? Прошивал прошивкой с задержкой отключения на 30 скунд. При подаче питания что должно быть на выходе тригера 1 или 0? Если перед датчиком нет ни кого

Заменил тиньку -результат тотже!!! При подачи питания на выходе тригер -1. Засветка исключена так как убрал светодиод под стол а приёмник на столе. Стоит отсоиденить от второй ноги резистор который идёт на базу транзюка вс817 через секунду на выходе 0. Тоже происходит и при разрыве цепи светодиода в любом месте. Подцеляю на место сразу на выходе 1. В чём косяк теряюсь в догатках! Вместо тиньки13 использовал 13а может в этом причина? Менял прошивку на родную всё тоже самое. В печатке вроде косяков нет если не трудно проверь


Вложения:
1.png
1.png [ 73.9 КБ | Просмотров: 844 ]
Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 31 май 2017, 08:43 
Не в сети
Аватара пользователя

Зарегистрирован: 29 май 2011, 17:59
Сообщения: 3687
Откуда: Россия
Начнём с того, что согласно твоей платы задействован выход «Статус», а выход «Триггер» никуда не подключён. Следующий момент: К контактам «свет плюс» и «свет минус» что подключается? Резистор на ИК–LED с каким сопротивлением? На входе стаба желательно поставить керамику на 0,1 мкФ.


Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 31 май 2017, 09:57 
Не в сети

Зарегистрирован: 22 май 2017, 12:37
Сообщения: 27
Откуда: омск
SVN писал(а):
Начнём с того, что согласно твоей платы задействован выход «Статус», а выход «Триггер» никуда не подключён. Следующий момент: К контактам «свет плюс» и «свет минус» что подключается? Резистор на ИК–LED с каким сопротивлением? На входе стаба желательно поставить керамику на 0,1 мкФ.

SVN Спасибо за помощь!!!! Я нашёл причину - это китайское фуфло купленное на али!!!! Поставил тиньку в дип корпусе купленную в нормальном магазине и всё сразу заработало!! Я в ШОКЕ!!!! Сколько я перепаял датчиков на простой логике но добиться таких результатов не смог и близко поэтому считал , что спаять датчик на ик отражении больше чем на 50 см не возможно и то при мощном светодиоде и порядка 150ма на нём! А тут при потреблении 7ма при сопротивлении 680 ом на светодиоде срабатывает на чёрные штаны уверенно на 1м 20 см!!!!!!На светлую одежду 1,5м!!! Чудо техники! Ай да парни , ай да светлые головы!!!! Но как всегда есть маленькая ложка дёктя в бочке мёда. Нет у меня нужной задержки на 30 секунд после выхода из поля зрения датчика. Может я скачал сырую прошивку? Или в чём может быть проблема? Начну по Вашим замечаниям.
1. С 7 ноги переподключил выходной транзюк на 5 ногу( тригер)
2. К контактам свет подключается светодиодная лента (небольшая потребляет 50ма)
3 Резистор ик 680 ом
4 Кондёр 0.1 на вход стаба поставлю но думаю что это не кретично так как питатся датчик будет от аккумулятора без подключения к сети 220.

Вот прошивка которой прошивал. Что не так ? Почему нет задержки 30 сек?


Вложения:
main_MOD1_b_30sec.hex [1.71 КБ]
Скачиваний: 26
Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 31 май 2017, 12:09 
Не в сети
Аватара пользователя

Зарегистрирован: 29 май 2011, 17:59
Сообщения: 3687
Откуда: Россия
порутчик писал(а):
Вот прошивка которой прошивал. Что не так ? Почему нет задержки 30 сек?

С какой страницы эта прошивка? Оригинальная прошивка с блога работает?


Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 31 май 2017, 15:12 
Не в сети

Зарегистрирован: 22 май 2017, 12:37
Сообщения: 27
Откуда: омск
SVN писал(а):
порутчик писал(а):
Вот прошивка которой прошивал. Что не так ? Почему нет задержки 30 сек?

С какой страницы эта прошивка? Оригинальная прошивка с блога работает?

SVN Прошу прощение!! Прошивка рабочая на 100 процентов. Был мой касяк! У меня осталось к Вам один вопрос
Не могли бы Вы изменить прошивку так чтоб датчик стал работать как ик барьер? Тоесть при пересечении луча на выходе 1 и держится минуты две. Возможно так изменить прошивку? Хочу поставить вограду .Там растояние метров 6 отражонка работать не будет а прямой луч точно будет.Сам бы с удовольствием поменял - если бы тямы хваталоб :D


Поставил купленную сегодня в чип и дип ATtiny13A-SU в корпусе so-8-208mm точно также как и тиньки с али в корпусе SO-8 не работает!!!!При подаче питания на выходе 1 и стоит постоянно!!! Ставлю в дип корпусе работает! Чем они отличаются? Датошит на все корпуса один и тот же. Ни чего не понимаю в чём косяк!!! Сперва тиньки прошивал потом паял ( паяю паяльной станцией перегрев исключён , не один десяток в со корпусах перепаял) Последнию прошил по месту. Прошилась без проблем но всё равно не работает!!! Какие мысли есть по этому поводу? Мож кто сталкивался с такой хренью?


Нашёл причину почему так работает датчик с тиньками в so-8 корпусе!!!! В место резистора на 300 ом идущего на вс817 поставил резистор на 4,7к . Ик резистор 1к дальность срабатывания датчика ввела меня в ступор. 2,5 МЕТРА!!!!!! Получается что при резисторе в 300 ом сила отражённого луча была такой что прошивала чёрную изоленту и пластиковый корпус в котором находится ик приёмник?Или возникала какая то паразитная обратная связь и тинька заклинивала?Это первая схема в моей не очень большой практике которая уже несколько раз меня удивляла. Интересно поиграться с дальностью меняя резисторы на ик светодиоде и на базе вс817.


Рано обрадовался! Датчик реагировал не на отражённый луч а на энергосберегающую лампу которая светила прямо на него. Вставая перед датчиком я загораживал её и он срабатывал, но через 30 сек отключался. Понял я это когда ик резистор догнал подбором до 100к! При таком резисторе ток через светодиот ничтожный и значит приёмник реагирует на что то другое. Выключил свет и сразу на выходе 1 и не отключается. В дип корпусе работало нормально. правда в темноте не пробывал. Как с этим бороться?


Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 31 май 2017, 20:47 
Не в сети
Аватара пользователя

Зарегистрирован: 29 май 2011, 17:59
Сообщения: 3687
Откуда: Россия
порутчик писал(а):
Не могли бы Вы изменить прошивку так чтоб датчик стал работать как ик барьер?

Как будет свободное время поэкспериментирую…

Цитата:
Поставил купленную сегодня в чип и дип ATtiny13A-SU в корпусе so-8-208mm точно также как и тиньки с али в корпусе SO-8 не работает!!!!При подаче питания на выходе 1 и стоит постоянно!!! Ставлю в дип корпусе работает!

Странно, у меня все тини в корпусах soic (ATtiny13A-SU и ATtiny13A-SSU) проблем не возникало.


Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 01 июн 2017, 09:09 
Не в сети

Зарегистрирован: 22 май 2017, 12:37
Сообщения: 27
Откуда: омск
SVN писал(а):
порутчик писал(а):
Не могли бы Вы изменить прошивку так чтоб датчик стал работать как ик барьер?

Как будет свободное время поэкспериментирую…

Цитата:
Поставил купленную сегодня в чип и дип ATtiny13A-SU в корпусе so-8-208mm точно также как и тиньки с али в корпусе SO-8 не работает!!!!При подаче питания на выходе 1 и стоит постоянно!!! Ставлю в дип корпусе работает!

Странно, у меня все тини в корпусах soic (ATtiny13A-SU и ATtiny13A-SSU) проблем не возникало.

Возникли проблемы и с тинькой в дип корпусе.Потестировал и обнаружил что датчик работает как таймер.Приподаче питания на выходе 0 через примерно30 сек появляется1 потом через 30 сек опять0 и так далее. Что то не катят мне эти ик датчики что на логике что на микроконтролёрах! :D


Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 01 июн 2017, 11:35 
Не в сети
Аватара пользователя

Зарегистрирован: 29 май 2011, 17:59
Сообщения: 3687
Откуда: Россия
порутчик писал(а):
Что то не катят мне эти ик датчики что на логике что на микроконтролёрах! :D

На нет и суда нет. (С) 8-)


Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 05 июн 2017, 22:16 
Не в сети

Зарегистрирован: 22 май 2017, 12:37
Сообщения: 27
Откуда: омск
SVN писал(а):
порутчик писал(а):
Что то не катят мне эти ик датчики что на логике что на микроконтролёрах! :D

На нет и суда нет. (С) 8-)

А ларчик то просто открывался!! Оказался глючный ик приёмник! Заменил и всё заработало на ура!!!


Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
 Заголовок сообщения: Re: Mod#094 (отключение триггера с задержкой)
СообщениеДобавлено: 27 фев 2018, 23:51 
Не в сети

Зарегистрирован: 22 май 2017, 12:37
Сообщения: 27
Откуда: омск
Может есть у кого исходники к датчику 094 на Ассемблере? Желательно с хорошими коментариями.


Вернуться к началу
 Профиль Отправить личное сообщение  
Ответить с цитатой  
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 161 ]  На страницу Пред.  1 ... 13, 14, 15, 16, 17  След.

Часовой пояс: UTC + 3 часа [ Летнее время ]


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 3


Вы можете начинать темы
Вы можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB