Перейти к блогу GetChip.net - блог        JilTE[1] - в разработке     Модификации устройств - модификации

 
Текущее время: 21 ноя 2018, 04:18

Часовой пояс: UTC + 3 часа [ Летнее время ]



Ответить
Имя пользователя:
Заголовок:
Текст сообщения:
Введите текст вашего сообщения. Длина сообщения в символах не более: 60000

Размер шрифта:
Цвет шрифта
Настройки:
BBCode ВКЛЮЧЁН
[img] ВКЛЮЧЁН
[flash] ВЫКЛЮЧЕН
[url] ВКЛЮЧЁН
Смайлики ВЫКЛЮЧЕНЫ
Отключить в этом сообщении BBCode
Не преобразовывать адреса URL в ссылки
Анти-спам
Анти-спам:
Выполните задание
   

Обзор темы - Mod#094 (отключение триггера с задержкой)
Автор Сообщение
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
Работает датчик очень просто. Устройство с определенным периодом посылает импульсы при помощи IR-светодиода. Инфракрасные лучи, отражаясь от объекта, принимаются инфракрасным приемником TSOP. Объект есть – есть сигнал, объекта нет – нет и сигнала. Дабы не было ложных срабатываний от бытовых пультов, помех, импульсов при включении света, устройством передается определенная последовательность импульсов и при декодировании TSOP, все что не совпадает с этой последовательностью – отбрасывается.


Уважаемый автор не могли бы Вы поделиться , как и с каким периодом посылаются импульсы, какая последовательность. Учу Ассемблер очень хочется понять (и повторить программно на Ассемблере) , как у Вас получилось добиться такой дальности на отражённом луче , при таком маленьком потреблении тока? У меня собранный датчик в тёмное время суток на отражённом луче бьёт около 4-ёх метров!
Помогите если не трудно чайнику! :D
Сообщение Добавлено: 01 мар 2018, 12:41
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
Может есть у кого исходники к датчику 094 на Ассемблере? Желательно с хорошими коментариями.
Сообщение Добавлено: 27 фев 2018, 23:51
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
SVN писал(а):
порутчик писал(а):
Что то не катят мне эти ик датчики что на логике что на микроконтролёрах! :D

На нет и суда нет. (С) 8-)

А ларчик то просто открывался!! Оказался глючный ик приёмник! Заменил и всё заработало на ура!!!
Сообщение Добавлено: 05 июн 2017, 22:16
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
порутчик писал(а):
Что то не катят мне эти ик датчики что на логике что на микроконтролёрах! :D

На нет и суда нет. (С) 8-)
Сообщение Добавлено: 01 июн 2017, 11:35
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
SVN писал(а):
порутчик писал(а):
Не могли бы Вы изменить прошивку так чтоб датчик стал работать как ик барьер?

Как будет свободное время поэкспериментирую…

Цитата:
Поставил купленную сегодня в чип и дип ATtiny13A-SU в корпусе so-8-208mm точно также как и тиньки с али в корпусе SO-8 не работает!!!!При подаче питания на выходе 1 и стоит постоянно!!! Ставлю в дип корпусе работает!

Странно, у меня все тини в корпусах soic (ATtiny13A-SU и ATtiny13A-SSU) проблем не возникало.

Возникли проблемы и с тинькой в дип корпусе.Потестировал и обнаружил что датчик работает как таймер.Приподаче питания на выходе 0 через примерно30 сек появляется1 потом через 30 сек опять0 и так далее. Что то не катят мне эти ик датчики что на логике что на микроконтролёрах! :D
Сообщение Добавлено: 01 июн 2017, 09:09
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
порутчик писал(а):
Не могли бы Вы изменить прошивку так чтоб датчик стал работать как ик барьер?

Как будет свободное время поэкспериментирую…

Цитата:
Поставил купленную сегодня в чип и дип ATtiny13A-SU в корпусе so-8-208mm точно также как и тиньки с али в корпусе SO-8 не работает!!!!При подаче питания на выходе 1 и стоит постоянно!!! Ставлю в дип корпусе работает!

Странно, у меня все тини в корпусах soic (ATtiny13A-SU и ATtiny13A-SSU) проблем не возникало.
Сообщение Добавлено: 31 май 2017, 20:47
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
SVN писал(а):
порутчик писал(а):
Вот прошивка которой прошивал. Что не так ? Почему нет задержки 30 сек?

С какой страницы эта прошивка? Оригинальная прошивка с блога работает?

SVN Прошу прощение!! Прошивка рабочая на 100 процентов. Был мой касяк! У меня осталось к Вам один вопрос
Не могли бы Вы изменить прошивку так чтоб датчик стал работать как ик барьер? Тоесть при пересечении луча на выходе 1 и держится минуты две. Возможно так изменить прошивку? Хочу поставить вограду .Там растояние метров 6 отражонка работать не будет а прямой луч точно будет.Сам бы с удовольствием поменял - если бы тямы хваталоб :D


Поставил купленную сегодня в чип и дип ATtiny13A-SU в корпусе so-8-208mm точно также как и тиньки с али в корпусе SO-8 не работает!!!!При подаче питания на выходе 1 и стоит постоянно!!! Ставлю в дип корпусе работает! Чем они отличаются? Датошит на все корпуса один и тот же. Ни чего не понимаю в чём косяк!!! Сперва тиньки прошивал потом паял ( паяю паяльной станцией перегрев исключён , не один десяток в со корпусах перепаял) Последнию прошил по месту. Прошилась без проблем но всё равно не работает!!! Какие мысли есть по этому поводу? Мож кто сталкивался с такой хренью?


Нашёл причину почему так работает датчик с тиньками в so-8 корпусе!!!! В место резистора на 300 ом идущего на вс817 поставил резистор на 4,7к . Ик резистор 1к дальность срабатывания датчика ввела меня в ступор. 2,5 МЕТРА!!!!!! Получается что при резисторе в 300 ом сила отражённого луча была такой что прошивала чёрную изоленту и пластиковый корпус в котором находится ик приёмник?Или возникала какая то паразитная обратная связь и тинька заклинивала?Это первая схема в моей не очень большой практике которая уже несколько раз меня удивляла. Интересно поиграться с дальностью меняя резисторы на ик светодиоде и на базе вс817.


Рано обрадовался! Датчик реагировал не на отражённый луч а на энергосберегающую лампу которая светила прямо на него. Вставая перед датчиком я загораживал её и он срабатывал, но через 30 сек отключался. Понял я это когда ик резистор догнал подбором до 100к! При таком резисторе ток через светодиот ничтожный и значит приёмник реагирует на что то другое. Выключил свет и сразу на выходе 1 и не отключается. В дип корпусе работало нормально. правда в темноте не пробывал. Как с этим бороться?
Сообщение Добавлено: 31 май 2017, 15:12
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
порутчик писал(а):
Вот прошивка которой прошивал. Что не так ? Почему нет задержки 30 сек?

С какой страницы эта прошивка? Оригинальная прошивка с блога работает?
Сообщение Добавлено: 31 май 2017, 12:09
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
SVN писал(а):
Начнём с того, что согласно твоей платы задействован выход «Статус», а выход «Триггер» никуда не подключён. Следующий момент: К контактам «свет плюс» и «свет минус» что подключается? Резистор на ИК–LED с каким сопротивлением? На входе стаба желательно поставить керамику на 0,1 мкФ.

SVN Спасибо за помощь!!!! Я нашёл причину - это китайское фуфло купленное на али!!!! Поставил тиньку в дип корпусе купленную в нормальном магазине и всё сразу заработало!! Я в ШОКЕ!!!! Сколько я перепаял датчиков на простой логике но добиться таких результатов не смог и близко поэтому считал , что спаять датчик на ик отражении больше чем на 50 см не возможно и то при мощном светодиоде и порядка 150ма на нём! А тут при потреблении 7ма при сопротивлении 680 ом на светодиоде срабатывает на чёрные штаны уверенно на 1м 20 см!!!!!!На светлую одежду 1,5м!!! Чудо техники! Ай да парни , ай да светлые головы!!!! Но как всегда есть маленькая ложка дёктя в бочке мёда. Нет у меня нужной задержки на 30 секунд после выхода из поля зрения датчика. Может я скачал сырую прошивку? Или в чём может быть проблема? Начну по Вашим замечаниям.
1. С 7 ноги переподключил выходной транзюк на 5 ногу( тригер)
2. К контактам свет подключается светодиодная лента (небольшая потребляет 50ма)
3 Резистор ик 680 ом
4 Кондёр 0.1 на вход стаба поставлю но думаю что это не кретично так как питатся датчик будет от аккумулятора без подключения к сети 220.

Вот прошивка которой прошивал. Что не так ? Почему нет задержки 30 сек?


Вложения:
main_MOD1_b_30sec.hex [1.71 КБ]
Скачиваний: 27
Сообщение Добавлено: 31 май 2017, 09:57
  Заголовок сообщения:  Re: Mod#094 (отключение триггера с задержкой)  
Цитата
Начнём с того, что согласно твоей платы задействован выход «Статус», а выход «Триггер» никуда не подключён. Следующий момент: К контактам «свет плюс» и «свет минус» что подключается? Резистор на ИК–LED с каким сопротивлением? На входе стаба желательно поставить керамику на 0,1 мкФ.
Сообщение Добавлено: 31 май 2017, 08:43

Часовой пояс: UTC + 3 часа [ Летнее время ]


Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Русская поддержка phpBB